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Broken Canary Index

Symptoms

  • Index search does not work for either the Canary or default.
  • Index is not working after Canary update.
  • Inconsistent data in the index between default and Canary.
  • Records imported via Importer, Updates and FullIndexer are not available in the index of the other system.
  • Two collections exist in Solr for the ADITO system, e.g. <My-Project>_prod and <My-Project-Canaray>_prod

Causes

  • ADITO versions use incompatible Solr versions.
  • ADITO versions use incompatible Solr ConfigSet versions.
  • Canary does not use the same collection as the default system, despite the Solr versions being compatible.
  • No periodic FullIndexer is configured to synchronize the two independent collections used, for incompatible ADITO versions.

How to verify

There are three distinct cases that require different solutions for the same problem.

  • Check if the Solr ConfigSet Version of the ADITO version and the Solr are the same or compatible in both Systems.
    • See the Versions and Dependencies page for more information.
    • The Solr versions must be the same for both systems to be compatible.
    • The ConfigSet version must be the same major and minor version. The bugfix version can differ.
      • e.g. 7.1.1 can be used together with 7.1.2 but not with 9.0.0

For compatible ADITO and Solr versions.

How to verify

Solution

  • Compatible Versions System can use the same index.

    • The same collection name must be specified in the alias configuration of the indexsearch for both the default and Canary system.
    • After the change, the ADITO system must be restarted.
    • Unused collections must be deleted via the AdminUI after the restart.
    important

    A restart of the ADITO system or the Indexsearch is required for the changes to take effect.

  • Deactivate both periodic FullIndexer server processes, if present from a previous canary update.

For incompatible ADITO and ConfigSet versions.

How to verify

Solution

  • Systems with incompatible versions must use the independent collections.

    • Define individual collection names in the alias configuration of the indexsearch for the default and Canary system.
    • After the change, the ADITO system must be restarted.
    important

    A restart of the ADITO system or the Indexsearch is required for the changes to take effect.

  • Add and start a periodic server process each that runs the FullIndexer to synchronize both collections.

    • As intervall use a value between a minimum of one hour and one day.
    • For bigger collections the intervall should be higher.

For incompatible ADITO and Solr versions.

How to verify

  • Check if each system uses an independent Solr service (Pod|Container).
    • Check via the Resources Tab in your SSP system page has an additional dedicated solr service adito-solr-<old|canaray>.
    • Compare if different remoteSolrUrl properties for each system's solr is configured.
  • Check via manager if a periodic server process for the FullIndexer is configured in both systems.

Solution

  • If no dedicated Solr service is configured for the canary system,

    • ask your IT or ADITO project manager to provide an additional solr service.
    • if not possible: Either downgrade the canary system or deactivate the indexsearch.
  • Systems with incompatible Solr versions must use the independent indexsearch aliases.

    • Define individual alias configurations with independent remoteSolrUrl values for the default and Canary system.
    • After the change, the ADITO system must be restarted.
    important

    A restart of the ADITO system or the Indexsearch is required for the changes to take effect.

  • Add and start a periodic server process each that runs the FullIndexer to synchronize both collections.

    • As intervall use a value between a minimum of one hour and one day.
    • For bigger collections the intervall should be higher.

Problem isn't solved?

Other guides for problems with similar symptoms

  • [Broken Index]->